Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

mail_open
Strange bug has appeared
Calum Roberts
Member
May 15, 2014 - 9:12 pm
Member Since: January 4, 2014
Forum Posts: 275
sp_UserOfflineSmall Offline

Hi all

We are experiencing a strange bug. Not sure if this is M2Epro related, or pickpack / shipeasy. Have allready contacted M2e about it, will also give Jim @Moogento a shout as well.

This bug is to do with importing orders. Not sure if its just Amazon orders its affecting or ebay an amazon yet.

What is happening is that when orders are imported, the last order has the previous orders items added to it. The prices are correct but the items list is not.

For example

3 Orders are imported in to magento using M2e from Amazon / eBay

Of course we now have a problem in that if we print of the orders they will have products on them that the customer hadnt ordered. And Magento doenst allow you to edit the orders. There are extensions to do this, but they are around $150
order 1 is for item A which is all good, no issues
Next order then has the the items from order 1 added to it.
Order 3 has the items from order 2 added to it.

The prices arent being adjusted, they are all correct, its just that the items from previous orders are being put into the newer orders.

I think its just when a batch of orders is imported together, this is happening to them. As no items from previous imports are being added to the new imported orders.

Will post up a reply when i M2e get back to me.

Im using the latest M2e version, so you may want to hold off on updating at the moment in case its that

kyle bihler
Reno, NV

Not so New
May 15, 2014 - 11:31 pm
Member Since: January 9, 2014
Forum Posts: 5
sp_UserOfflineSmall Offline

I am seeing similar behavior it must be M2E cause we do not have pickpack / shipeasy. However on ours it is applying the pricing of the first order to the others.

Calum Roberts
Member
May 16, 2014 - 1:44 am
Member Since: January 4, 2014
Forum Posts: 275
sp_UserOfflineSmall Offline

Thanks for confirming Kyle

Ive been looking and im getting the same, pricing is being altered as well on the orders to the first item being pulled in. So it does seem its a fairly nasty bug in the latest version.

The only way i can see around it is deleting the order, then going into the sales chanel of the amazon listing and creating a new order from there to get it looking right until M2e fix it

Avatar
Matthew Ogborne

Founder
May 16, 2014 - 4:38 am
Member Since: July 18, 2013
Forum Posts: 4565
sp_UserOfflineSmall Offline

Howdy Kyle, Calum,

Ouchy that sounds nasty.

Really daft question, you both have tickets in with M2E with examples?

Matt

"Selling an item online is easy, but making living from a business that sells online, well that’s something different entirely!"

Ultimo Magento Theme

john ayres

Excellent
May 16, 2014 - 6:49 am
Member Since: March 21, 2014
Forum Posts: 12
sp_UserOfflineSmall Offline

I just installed M2E and set up for Amazon, got 45 orders all showing items building up on next order, seems to be in batches as it clears after 8 or so orders, made a complete mess of Magento orders and had to disable as soon as we saw it.
Will now have to install a ‘Delete Orders’ plug in to clean up Magento and reconsider whether M2E is the right way to go for Amazon or if we should stick with Linnworks for Amazon and only use M2E for eBay, been using LW for 6 years without problems like this – it really is true that you get what you pay for, M2E for Amazon costs nothing!!!

Calum Roberts
Member
May 16, 2014 - 7:54 am
Member Since: January 4, 2014
Forum Posts: 275
sp_UserOfflineSmall Offline

Hi John

To be fair, the amazon part of M2e is still in beta. I should have held off for a couple of weeks updating, lesson learned.

I have sent off a support email to M2e reporting the issue, but others need to do it as well so that they realize its a serious bug

john ayres

Excellent
May 16, 2014 - 8:08 am
Member Since: March 21, 2014
Forum Posts: 12
sp_UserOfflineSmall Offline

Hi Calum,
we didn’t have the choice of which version to use as we’ve only just started and from everything we read so far the Amazon side was said to work ok, to put out an update that has such a bad bug suggest the testing was minimal if not non existent.
I think I will wait to use the Amazon side until they start charging and put some resources into getting it right.

kyle bihler
Reno, NV

Not so New
May 16, 2014 - 5:58 pm
Member Since: January 9, 2014
Forum Posts: 5
sp_UserOfflineSmall Offline

I am opening a ticket now. I think the issue is deeper than just on the Amazon side as I have had an ebay order come in first correctly and right behind it comes an amazon order with the ebay item appended to it, and vice versa. This is the first glaring bug I have encountered with m2e, sure some little things but they were easy to work around, and I have been using and upgrading it for a full year now. I’m sure it will get straightened out.

For any one reading this, hold off on upgrading from m2e 6.1.0 to 6.1.4 or 6.1.5. 6.1.0 is the last version that was working just fine, for me.

Avatar
Dave Furness

Founder
May 16, 2014 - 7:03 pm
Member Since: July 19, 2013
Forum Posts: 4606
sp_UserOfflineSmall Offline

Hey Kyle

Wow your right this does sound weird! Let’s us know what M2E get back to
You with as I’m curious to know what could be causing this

Dave

Every expert was once a beginner

Calum Roberts
Member
May 16, 2014 - 9:00 pm
Member Since: January 4, 2014
Forum Posts: 275
sp_UserOfflineSmall Offline

Just got an email back from M2e pro who we’re given log in details to my site

They have said that it has been fixed, as usual no details as to what was wrong etc.

I will check to see if it’s now working properly.

I would imagine they will be pushing a new version shortly onto magento connect if it is indeed fixed.

Will keep you updated

Avatar
Dave Furness

Founder
May 16, 2014 - 11:25 pm
Member Since: July 19, 2013
Forum Posts: 4606
sp_UserOfflineSmall Offline

Yea I imagine they will bundle it with the update to support Mag 1.9…or if not like you say, they will push one out before

Dave

Every expert was once a beginner

Calum Roberts
Member
May 17, 2014 - 6:32 pm
Member Since: January 4, 2014
Forum Posts: 275
sp_UserOfflineSmall Offline

I can confirm that M2e have fixed the bug on my store, have now stopped having order items merged in the next orders.

Excellent response from them even if a little sparse on the details

Avatar
Matthew Ogborne

Founder
May 18, 2014 - 7:52 am
Member Since: July 18, 2013
Forum Posts: 4565
sp_UserOfflineSmall Offline

Hi Calum,

I’m really glad to hear that they’ve sorted it.

I know what you mean on being sparse on details, the main thing is that it’s resolved.

Matt

"Selling an item online is easy, but making living from a business that sells online, well that’s something different entirely!"

Ultimo Magento Theme

kyle bihler
Reno, NV

Not so New
May 19, 2014 - 5:35 pm
Member Since: January 9, 2014
Forum Posts: 5
sp_UserOfflineSmall Offline

They fixed up ours as well. Less than 24 hour turn around! I am based in Nevada, USA, not even sure where they are. Could not ask for better service especially for free. Big thanks to the m2e team!

Avatar
Dave Furness

Founder
May 19, 2014 - 9:12 pm
Member Since: July 19, 2013
Forum Posts: 4606
sp_UserOfflineSmall Offline

Happy Day Calum, I believe there main team is based just outside of London here in the UK

:)

Dave

Every expert was once a beginner

 

Why Should You Join UnderstandingE?

 
  • Access to over 500 step-by-step video tutorials
  • +20 video courses available
  • Magento, M2E Pro, Magmi, eBay, Amazon & Design all covered
  • Everything is in 100% Plain English
  • Learn how to build your own multi-channel software for eBay & Amazon
  • Access to the community forums, meet fellow business owners like yourself

Join Now with 2 Clicks

 

Join now for less that £1 per day you can gain access to over 400 step-by-step video tutorials & learn how to build your very own multi-channel software.

 

Forum Timezone: Europe/London

Most Users Ever Online: 1012

Currently Online:
18 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Jim @ Moogento: 688

Steve Froggatt: 514

Badeth - UE: 513

Jimbob: 453

Paul Cartwright: 414

Forum Stats:

Groups: 6

Forums: 37

Topics: 5221

Posts: 27486

Administrators: Matthew Ogborne: 4565, Dave Furness: 4606