Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

mail_open
Magmi 0.7.22 won't properly import and index url keys in Magento EE 1.13.1
korym

Excellent
April 25, 2016 - 6:21 pm
Member Since: March 4, 2015
Forum Posts: 11
sp_UserOfflineSmall Offline

Hi All,

I cannot find a concrete answer after an exhaustive search and I really need an answer to this question:

Does Magmi 0.7.22 support url key imports into EE 1.13.1?

On older Magmi versions, it would not import the url key into the proper table for EE url keys:

catalog_product_entity_url_key catalog_url_rewrite_product_cl

The only place I could find the url key was in admin, and that was due to the fact it was in the catalog_product_entity_varchar table, which makes sense.

But, when I reindex, the entry is not created in enterprise_url_rewrite. Perplexing b/c the entry in cl should trigger that, although I had tested this before by adding the record directly into the catalog_product_entity_url_key, again seeing the similar entry into the cl table, reindexing, but the same lack of entry into enterprise_url_rewrite.

Lastly, I see the update on GIThub on the “fix for url key unique index”:

https://sourceforge.net/p/magmi/git/ci/8f3efc48140e4205350c92ece3526d04748fc713/

I did change this file in my .22 install and tried again, still no luck.

I have 0.7.22 installed, and downloaded the complete zip for 0.7.23 from the master GIT. I haven’t installed that yet, but (and pardon my ignorance here) would I just upload all the files in the .23 Magmi folder over the installed .22 files on my installation? Would you recommend .23? No one really seems to speak to this.

Thanks so much in advance for your help with this issue.

Kory

korym

Excellent
April 27, 2016 - 3:24 pm
Member Since: March 4, 2015
Forum Posts: 11
sp_UserOfflineSmall Offline

I resolved this. It works. If it doesn’t work, which it didn’t in my test environment, but did in my live, flush the enterprice_url_rewrite table and run the indexes.

That makes it work.

Dave Furness

Founder
May 4, 2016 - 9:20 am
Member Since: July 19, 2013
Forum Posts: 4606
sp_UserOfflineSmall Offline

Glad you got it working Kory and thanks for sharing the solution.

Dave

Every expert was once a beginner

 

Why Should You Join UnderstandingE?

 
  • Access to over 500 step-by-step video tutorials
  • +20 video courses available
  • Magento, M2E Pro, Magmi, eBay, Amazon & Design all covered
  • Everything is in 100% Plain English
  • Learn how to build your own multi-channel software for eBay & Amazon
  • Access to the community forums, meet fellow business owners like yourself

Join Now with 2 Clicks

 

Join now for less that £1 per day you can gain access to over 400 step-by-step video tutorials & learn how to build your very own multi-channel software.

 

Forum Timezone: Europe/London

Most Users Ever Online: 1012

Currently Online:
16 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Jim @ Moogento: 688

Steve Froggatt: 514

Badeth - UE: 513

Jimbob: 453

Paul Cartwright: 414

Forum Stats:

Groups: 6

Forums: 37

Topics: 5223

Posts: 27502

Administrators: Matthew Ogborne: 4565, Dave Furness: 4606