Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

mail_open
"Use Web Server Rewrites" & M2Epro - Whats the connection?
David Patterson
Member
May 3, 2014 - 9:04 pm
Member Since: April 13, 2014
Forum Posts: 127
sp_UserOfflineSmall Offline

@matt – I think i heard you say on one of the videos that you recommend turning on “Use Web Server Rewrites” and that it has something to do with M2Epro. What is the connection? After I turned mine on I started getting the following error message:

server-error-message.jpgImage Enlarger

I contacted my hosting provider 1and1 (i had opened an account before i came across your recommendation for simple servers) and they fixed the problem by turning off “Use Web Server Rewrites”.

sp_PlupAttachments Attachments
Avatar
Matthew Ogborne

Founder
May 5, 2014 - 8:08 am
Member Since: July 18, 2013
Forum Posts: 4565
sp_UserOfflineSmall Offline

Hi David,

Just to clarify, the reason for this so that you get nice urls on your website, so parts.html not something like /catalog/category/id/22

The 500 error, that’s the webserver saying “urh something went wrong, but I’m not sure quite what went wrong and I’m not telling you either”.

So this could be a collection of things, the most obvious one is that in the .htaccess file in the root directory for your Magento installation, make sure that “RewriteEngine on” doesn’t have a # symbol in front of it.

And also the same for “RewriteRule .* index.php [L]” too.

And also this is most likely to be it, in your .htaccess file, remove the # from these lines:

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

I contacted my hosting provider 1and1 (i had opened an account before i came across your recommendation for simple servers) and they fixed the problem by turning off “Use Web Server Rewrites”.

If the above doesn’t solve it (which it should do). What I would do is turn it on and then call a page, then check the error logs and see what messages are being left behind as they’ll give you the reasons for the 500 error message.

I also had a quite search around and found these links that may help:

http://stackoverflow.com/questions/6956997/magento-500-internal-server-error
http://www.magentocommerce.com/boards/viewthread/199907
http://www.magentocommerce.com/boards/viewthread/18974/
https://drupal.org/node/232773 ( Drupal but suggests setting “RewriteBase /” explcitly )

And a general summary of these, points to it being handlers mentioned at the beginning.

Let me know how you get on.

Matt

"Selling an item online is easy, but making living from a business that sells online, well that’s something different entirely!"

Ultimo Magento Theme

 

Why Should You Join UnderstandingE?

 
  • Access to over 500 step-by-step video tutorials
  • +20 video courses available
  • Magento, M2E Pro, Magmi, eBay, Amazon & Design all covered
  • Everything is in 100% Plain English
  • Learn how to build your own multi-channel software for eBay & Amazon
  • Access to the community forums, meet fellow business owners like yourself

Join Now with 2 Clicks

 

Join now for less that £1 per day you can gain access to over 400 step-by-step video tutorials & learn how to build your very own multi-channel software.

 

Forum Timezone: Europe/London

Most Users Ever Online: 1012

Currently Online:
38 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Jim @ Moogento: 688

Steve Froggatt: 514

Badeth - UE: 513

Jimbob: 453

Paul Cartwright: 414

Forum Stats:

Groups: 6

Forums: 37

Topics: 5221

Posts: 27485

Administrators: Matthew Ogborne: 4565, Dave Furness: 4606