Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

mail_open
Ebay Not Accepting EAN Identifiers
Avatar
Jimbob
UK
Member
February 23, 2016 - 4:01 pm
Member Since: November 15, 2013
Forum Posts: 453
sp_UserOfflineSmall Offline

Hi,

Ebay does not appear to be allowing me to submit EAN’s with products I list or revise despite having correctly configured my M2E descriptions policy as follows;

listing policyImage Enlarger

When I try to list or revise a product I get the following error message; ‘The value of EAN was no sent because it is not allowed in this Category’

I have contacted M2E Pro support and they provided the following reply;

Hello James,

The warning you receive ‘The value of EAN was no sent because it is not allowed in this Category’ is returned to inform you that M2E Pro sends the EAN values you set for this product, however, the data is not accepted by eBay API for this eBay category.

We may assume, eBay allows you providing the EAD identifiers for the products manually on the channel, while eBay API does not validate the same values for the same eBay category.

At this point, you can either set EAN for the product directly on eBay or try to verify why eBay API identifies EAN as not allowed for this eBay category.

Best Regards,
M2E Pro Support Team.

I have contacted Ebay and they say it is the M2E Pro listing tool and M2E Pro say it is Ebay’s API.

Has anyone had the same issue and does anyone have a solution?

Thanks

Adventurist and online ecommerce retailer based in the UK. Trading since 2006.

Badeth - UE
Member
February 24, 2016 - 6:40 am
Member Since: October 23, 2015
Forum Posts: 513
sp_UserOfflineSmall Offline

Hi Jimbob,

Have you tried the suggestions from M2E pro guys?

Thanks,
Badeth

Avatar
Jimbob
UK
Member
February 24, 2016 - 10:00 am
Member Since: November 15, 2013
Forum Posts: 453
sp_UserOfflineSmall Offline

Hi Badet,

I am able to set them manually on Ebay and I have also contacted ebay, but they are maintaining that it is an issue with M2E Pro.

Confused

Adventurist and online ecommerce retailer based in the UK. Trading since 2006.

martyn2385

Excellent
July 21, 2016 - 1:50 pm
Member Since: July 20, 2016
Forum Posts: 13
sp_UserOfflineSmall Offline

Hi,

I am a bit late to respond here but better late than never. I had this problem and actually read this post whilst looking for a solution. I have yet to find a FULL solution online but I did figure it out in the end by matching snippets from EAN / M2EPRO problem posts, so I thought I would share the my solution so far here

1) Make sure EAN is available in ALL attribute sets, even the sets you do not use.
a. Add EAN to all attribute sets
b. Catalog -> Attributes -> Manage Attribute Sets -> Stick EAN in them ALL

2) Within the descriptions policy mark EAN as “NOR REQUIRED”, don’t ask me why.
a. Sell On eBay -> Configuration -> Policies -> Your description policy -> eBay Catalog Identifiers -> EAN “Does Not Apply”

3) Go to the Magento Admin Screen and follow this path (Prerequisite – you have a category in use) my item uploaded to category 52554 without an EAN (by fluke, I don’t know why the product was completely unrelated), I then changed this category to a category that I do use and mapped all the my pre-set Attributes Set aka item specifics including EAN as a “Custom Label/Attribute”.
The Path -> Sell On eBay -> Configuration -> Categories In Use -> Click “Edit” -> “Specifics” Tab beside general then “Add Custom Specific” as “Custom Label/Attribute” and MAP your EAN

Now onto multiple pictures Smile

This worked for me and I hope this helps someone else.

21-07-2016 So i listed my first item using the method above and although the EAN item specific is filled in, upon Revising the item via eBay individually, eBay throws up two EAN fields in the item Specifics one is filled with the EAN number i mapped via the attributes and the other contains Does Not Apply. I will post a correct solution here when I get one.

The confusing thing is “EAN: Does Not Apply” does not appear in the listings item specifics but my Attribute EAN does. Does this mean eBay have accepted it? Does anyone have any thoughts on the correct way to sort this flaw?

Martyn

 

Why Should You Join UnderstandingE?

 
  • Access to over 500 step-by-step video tutorials
  • +20 video courses available
  • Magento, M2E Pro, Magmi, eBay, Amazon & Design all covered
  • Everything is in 100% Plain English
  • Learn how to build your own multi-channel software for eBay & Amazon
  • Access to the community forums, meet fellow business owners like yourself

Join Now with 2 Clicks

 

Join now for less that £1 per day you can gain access to over 400 step-by-step video tutorials & learn how to build your very own multi-channel software.

 

Forum Timezone: Europe/London

Most Users Ever Online: 1012

Currently Online:
27 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Jim @ Moogento: 688

Steve Froggatt: 514

Badeth - UE: 513

Jimbob: 453

Paul Cartwright: 414

Forum Stats:

Groups: 6

Forums: 37

Topics: 5221

Posts: 27483

Administrators: Matthew Ogborne: 4565, Dave Furness: 4606