Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

mail_open
Unable to list to current working directory
Alex Lockey
Member
January 31, 2014 - 3:13 pm
Member Since: January 1, 2014
Forum Posts: 107
sp_UserOfflineSmall Offline

Hi,

I recently updated Magento (the safe way!) and migrated hosts. I’ve had a few problems with migrating to a different hosting, the latest being that when I attempted to upload an individual image to a listing I received the error message ‘Destination folder does not exist.’ I found this workaround http://www.magentocommerce.com…..read/1936/ and subsequently changed all my permissions from 755s to 777s in the folders:

1. “MEDIA” folder
2. in MEDIA folder to “CATALOG” and “ TMP” and ALL subfolders individually.

Now, I can upload some images but not others. For instance, some images upload then give an error ‘Unable to list current working directory’ when the product is saved. Whereas others upload, allow me to save, then the product preview doesn’t work and they don’t work on my site?

I read somewhere that the ‘unable to list current working directory’ may have something to do with characters in the file names of images; the image files which allow upload have filenames without any dodgy characters. They still don’t display though, just give a broken picture icon.

Beyond this, I’m a bit stuck?!

Avatar
Matthew Ogborne

Founder
February 3, 2014 - 2:35 am
Member Since: July 18, 2013
Forum Posts: 4565
sp_UserOfflineSmall Offline

Howdy Alex,

This is a question for your hosting provider, as I suspect that they’ve got a proxy or varnish on the front that is blocking it.

Matt

"Selling an item online is easy, but making living from a business that sells online, well that’s something different entirely!"

Ultimo Magento Theme

Alex Lockey
Member
February 3, 2014 - 11:21 am
Member Since: January 1, 2014
Forum Posts: 107
sp_UserOfflineSmall Offline

Hi,

I had not given the full permissions to the full folder. My host ran

chmod -R 777 media/

and it’s now working fine….!

Cheers

Avatar
Matthew Ogborne

Founder
February 3, 2014 - 12:14 pm
Member Since: July 18, 2013
Forum Posts: 4565
sp_UserOfflineSmall Offline

YAY!

Matt

"Selling an item online is easy, but making living from a business that sells online, well that’s something different entirely!"

Ultimo Magento Theme

 

Why Should You Join UnderstandingE?

 
  • Access to over 500 step-by-step video tutorials
  • +20 video courses available
  • Magento, M2E Pro, Magmi, eBay, Amazon & Design all covered
  • Everything is in 100% Plain English
  • Learn how to build your own multi-channel software for eBay & Amazon
  • Access to the community forums, meet fellow business owners like yourself

Join Now with 2 Clicks

 

Join now for less that £1 per day you can gain access to over 400 step-by-step video tutorials & learn how to build your very own multi-channel software.

 

Forum Timezone: Europe/London

Most Users Ever Online: 1012

Currently Online:
32 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Jim @ Moogento: 688

Steve Froggatt: 514

Badeth - UE: 513

Jimbob: 453

Paul Cartwright: 414

Forum Stats:

Groups: 6

Forums: 37

Topics: 5221

Posts: 27486

Administrators: Matthew Ogborne: 4565, Dave Furness: 4606