Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

No permission to create posts
mail_open
Magmi & Commas - Import Issue
Avatar
Jimbob
UK
Member
March 9, 2014 - 1:42 pm
Member Since: November 15, 2013
Forum Posts: 453
sp_UserOfflineSmall Offline

Hi,

Magmi will NOT import any product lines that have a cell containing commas. For example if I add copy for a product description that has no commas Magmi imports perfectly, but not if any commas are included.

For example Magmi will not import the product on row 3 of this table;

tableImage Enlarger

Can anyone advise why this is happening?

Is it anything to do with the option shown below during the process of saving the table as a csv file?

save processImage Enlarger

Adventurist and online ecommerce retailer based in the UK. Trading since 2006.

Avatar
Matthew Ogborne

Founder
March 10, 2014 - 11:59 am
Member Since: July 18, 2013
Forum Posts: 4565
sp_UserOfflineSmall Offline

Howdy James,

I’ve just tested this with Magmi and she’s imported ok with a comma, see the attached files and screen shot.

You’re using a mac and I’m not 100% sure on the settings that you need, however I know @Alex Lockey uses a mac and might be able to help us.

Attachments below:

example-import.pngImage Enlarger

sp_PlupAttachments Attachments
"Selling an item online is easy, but making living from a business that sells online, well that’s something different entirely!"

Ultimo Magento Theme

Alex Lockey
Member
March 10, 2014 - 1:31 pm
Member Since: January 1, 2014
Forum Posts: 107
sp_UserOfflineSmall Offline

Hi James,

I think it might be because you’re saving the file as tab-delimited text (.txt). Try File>Save As> and choose Windows Comma Separated (.csv) as your format.

I know I’ve hit problems when not importing this file type through Magmi from a mac, let me know how it goes!

Cheers

Avatar
Matthew Ogborne

Founder
March 11, 2014 - 9:59 pm
Member Since: July 18, 2013
Forum Posts: 4565
sp_UserOfflineSmall Offline

Howdy James,

I’m curious, how did you get on ?

Matt

"Selling an item online is easy, but making living from a business that sells online, well that’s something different entirely!"

Ultimo Magento Theme

Avatar
Jimbob
UK
Member
March 12, 2014 - 10:18 am
Member Since: November 15, 2013
Forum Posts: 453
sp_UserOfflineSmall Offline

Hi Matt,

I am still struggling to resolve this. I can import the below data that contains no commas;

DataImage Enlarger

However, Magmi just will not import data as shown below where I have added data to column F;

data with commasImage Enlarger

I am using OpenOffice to prepare and save my data and choose the following format to save data; Text CSV (.csv)

ConfusedConfused

Adventurist and online ecommerce retailer based in the UK. Trading since 2006.

Avatar
Matthew Ogborne

Founder
March 12, 2014 - 10:59 am
Member Since: July 18, 2013
Forum Posts: 4565
sp_UserOfflineSmall Offline

Hi James,

Try these settings when saving:

Untitled-2.pngImage Enlarger

Also trying the “Unicode (UTF-8)” might be worth a whirl.

Matt

"Selling an item online is easy, but making living from a business that sells online, well that’s something different entirely!"

Ultimo Magento Theme

Catherine Graham

Excellent
March 18, 2014 - 2:29 pm
Member Since: January 13, 2014
Forum Posts: 30
sp_UserOfflineSmall Offline

I’d be interested in knowing if you solved this?
I had a problem with uploading the visibility column and didn’t realise the comma was the issue.

Avatar
Jimbob
UK
Member
March 19, 2014 - 4:41 pm
Member Since: November 15, 2013
Forum Posts: 453
sp_UserOfflineSmall Offline

Hi Guys,

I have not been able to solve this and I have tried saving as per Matt’s advice above.

I have tried saving the .csv with the following character sets selected;

Unicode (UTF-8)
Unicode (UTF-7)
Western European (Windows-1251/WinLatin 1)
Western European (ISO-8859-15/EURO)
Western European (ISO-8859-14)
Western European (ISO-8859-1)
Western European (Apple Macintosh)

However, I am still unable to import any .csv file that includes a column where its content has commas as shown below in column G (description);

Image Enlarger

I can save and import any file which does not have any commas in the column fields as shown below;

Image Enlarger

Adventurist and online ecommerce retailer based in the UK. Trading since 2006.

Avatar
Sebastien BRACQUEMONT

Excellent
March 20, 2014 - 10:20 am
Member Since: January 9, 2014
Forum Posts: 34
sp_UserOfflineSmall Offline

Hi,

This is a weird issue. While excel is poor as proposing CSV saving options , it should at least enclose values containing commas with double quotes if the data separator is comma.

So i would need extra information :
The version of Excel & OS your are using.
Could you attach the faulty csv file with your next comment ?
What problem does magmi report at importing ?

Avatar
Jimbob
UK
Member
March 20, 2014 - 12:26 pm
Member Since: November 15, 2013
Forum Posts: 453
sp_UserOfflineSmall Offline

Hi Sebastien,

I am using

  • OS X 10.9.2
  • Open Office 4.0.1
  • Magmi Startup Info

    Running Magmi Product Import Engine v1.7.1 by dweeves
    Import Profile:default
    Import Mode:update
    CSV Datasource v1.3 – Importing CSV : /home/gigglebe/public_html/var/import/variations with commas.csv using separator [ , ] enclosing [ \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\” ]
    Performing Datasouce Lookup…
    Found 10 records, took 0.00106811523438 sec
    CSV Datasource v1.3 – No BOM detected, assuming File is UTF8 without BOM…
    CSV Datasource v1.3 – 7 CSV headers columns found
    Image attributes processor v1.0.25 – no image attributes found in datasource, disabling image processor
    Configurable Item processor v1.3.7 – no options_container set, defaulting to :Block after product info
    Ajusted processed columns:9

    Magmi Warnings

    It is not unusually to get this type of warning even on successful imports.

    Warning: Invalid argument supplied for foreach() in /home/gigglebe/public_html/magmi-importer web/progress_details.php on line 23

    Run Time Info

    Magmi Optimizer v1.0.5 – Optimizing magmi
    Magmi Optimizer v1.0.5 – Adding index MAGMI_EAOV_OPTIMIZATION_IDX on eav_attribute_option_value
    Magmi Optimizer v1.0.5 – Already optmized!
    Magmi Optimizer v1.0.5 – Adding index MAGMI_CPEM_OPTIMIZATION_IDX on catalog_product_entity_media_gallery
    Magmi Optimizer v1.0.5 – Already optmized!
    Magmi Optimizer v1.0.5 – Adding index MAGMI_CCEV_OPTIMIZATION_IDX on catalog_category_entity_varchar
    Magmi Optimizer v1.0.5 – Already optmized!
    Magmi Optimizer v1.0.5 – Adding index MAGMI_EA_CODE_OPTIMIZATION_IDX on eav_attribute
    Magmi Optimizer v1.0.5 – Already optmized!
    Skus imported OK:0/0

    The attached file imports successfully when the commas are removed, but will not import with the commas as included in the attached file.

    Thanks

    Adventurist and online ecommerce retailer based in the UK. Trading since 2006.

    Avatar
    Sebastien BRACQUEMONT

    Excellent
    March 20, 2014 - 1:38 pm
    Member Since: January 9, 2014
    Forum Posts: 34
    sp_UserOfflineSmall Offline

    Ok, now i understand what’s happenning !

    CSV Datasource v1.3 – Importing CSV : /home/gigglebe/public_html/var/import/variations with commas.csv using separator [ , ] enclosing [ \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\" ]

    This means the PHP settings on your server have the magic_quotes_gpc flags set.

    What happens is that when the UI wants to save the enclosure char (here the ” ) , PHP automatically “escapes” the value before it is transmitted.

    For magmi UI to work correctly, you need to have this settings “off” & resave your profile.

    Avatar
    Jimbob
    UK
    Member
    March 20, 2014 - 2:14 pm
    Member Since: November 15, 2013
    Forum Posts: 453
    sp_UserOfflineSmall Offline

    Hi Sebastian,

    Thanks for identifying that for me, but it all sounds gobbledigook to me. Is this a setting on my server that I need to ask my web host to change and if so can you advise me what it is that I specifically need to instruct/ask them to do?

    Regards

    James

    Adventurist and online ecommerce retailer based in the UK. Trading since 2006.

    Avatar
    Sebastien BRACQUEMONT

    Excellent
    March 20, 2014 - 2:41 pm
    Member Since: January 9, 2014
    Forum Posts: 34
    sp_UserOfflineSmall Offline

    ask them the following.

    either : create a .htaccess file in magmi directory with the following line:

    php_flag magic_quotes_gpc off

    or, if the above solution is restricted (might happen in some web hosters configuration):

    modifiy php.ini file for your hosting configuration with the following line:

    magic_quotes_gpc=off
    Avatar
    Jimbob
    UK
    Member
    March 20, 2014 - 2:50 pm
    Member Since: November 15, 2013
    Forum Posts: 453
    sp_UserOfflineSmall Offline

    Thanks.

    I think I can do that myself as I have access to the required directory. I think I have created the htaccess file as attached and once uploaded I just need to rename to .htaccess?

    Adventurist and online ecommerce retailer based in the UK. Trading since 2006.

    Avatar
    Sebastien BRACQUEMONT

    Excellent
    March 20, 2014 - 2:55 pm
    Member Since: January 9, 2014
    Forum Posts: 34
    sp_UserOfflineSmall Offline

    indeed

    Avatar
    Jimbob
    UK
    Member
    March 20, 2014 - 2:57 pm
    Member Since: November 15, 2013
    Forum Posts: 453
    sp_UserOfflineSmall Offline

    I have just uploaded it to the following directory public_html/magmi-importer and renamed it .htaccess, but when I try to launch Magmi in my browser I get a 404 page?

    Adventurist and online ecommerce retailer based in the UK. Trading since 2006.

    Avatar
    Sebastien BRACQUEMONT

    Excellent
    March 20, 2014 - 2:59 pm
    Member Since: January 9, 2014
    Forum Posts: 34
    sp_UserOfflineSmall Offline

    put this .htaccess file in the magmi/web directory i think. this is the “sensible” part

    Avatar
    Jimbob
    UK
    Member
    March 20, 2014 - 3:00 pm
    Member Since: November 15, 2013
    Forum Posts: 453
    sp_UserOfflineSmall Offline

    Hi,

    I tried that and it does the same.

    Adventurist and online ecommerce retailer based in the UK. Trading since 2006.

    Catherine Graham

    Excellent
    March 20, 2014 - 3:04 pm
    Member Since: January 13, 2014
    Forum Posts: 30
    sp_UserOfflineSmall Offline

    I also need to do this…. I couldn’t understand why I was getting ////////” all the time.
    I have found the .htaccess folder in Filezilla, but unsure how to add
    php_flag magic_quotes_gpc off
    to this folder? Please can you give exact details on how to do this.
    Thx!

    Avatar
    Sebastien BRACQUEMONT

    Excellent
    March 20, 2014 - 3:09 pm
    Member Since: January 9, 2014
    Forum Posts: 34
    sp_UserOfflineSmall Offline

    In this case, ask your hosting administrator to ensure the magic_quotes_gpc flag is not set for the magmi installation. Since he knows his job & his platform, he would know how to do it.

    No permission to create posts

     

    Why Should You Join UnderstandingE?

     
    • Access to over 500 step-by-step video tutorials
    • +20 video courses available
    • Magento, M2E Pro, Magmi, eBay, Amazon & Design all covered
    • Everything is in 100% Plain English
    • Learn how to build your own multi-channel software for eBay & Amazon
    • Access to the community forums, meet fellow business owners like yourself

    Join Now with 2 Clicks

     

    Join now for less that £1 per day you can gain access to over 400 step-by-step video tutorials & learn how to build your very own multi-channel software.

     

    Forum Timezone: Europe/London

    Most Users Ever Online: 1012

    Currently Online:
    27 Guest(s)

    Currently Browsing this Page:
    1 Guest(s)

    Top Posters:

    Jim @ Moogento: 688

    Steve Froggatt: 514

    Badeth - UE: 513

    Jimbob: 453

    Paul Cartwright: 414

    Forum Stats:

    Groups: 6

    Forums: 37

    Topics: 5221

    Posts: 27485

    Administrators: Matthew Ogborne: 4565, Dave Furness: 4606