Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

mail_open
Bundle Products not showing in category and search page using Magmi v0.7.19a and Magento CE 1.8.1
Tousif Ahmed

New
July 31, 2014 - 7:52 pm
Member Since: July 31, 2014
Forum Posts: 1
sp_UserOfflineSmall Offline

In my search for importing bundle products, found Magmi.The tutorials and videos on this site helped a lot, thanks.

I have created a sample csv file to import bundled procucts. There are two problems I am currently facing in the process.

1> After importing the options don’t show up until I save the product from the admin area.

2> The product is visible in admin area with all the options after importing and also visible when accessed through the url_key but the product is not visible in category and search pages.

I have attached my sample csv incase that helps.
Any help will be highly appreciated.
Thanks.

Avatar
Matthew Ogborne

Founder
August 1, 2014 - 12:48 pm
Member Since: July 18, 2013
Forum Posts: 4565
sp_UserOfflineSmall Offline

Hi Tousif,

OK the key point here is that Magmi is a database extension, not a magento extension.

What that means is that Magmi is adding this information to Magento‘s database and not using the magento core code.

This does mean that for changes to be reflected properly on the site and sometimes in the admin (quite rare as the admin is nearly always right) the site needs to be reindexed.

So with that in mind, make an import to create a new bundle, reindex and confirm its showing OK on the front end.

Hope that helps,

Matt

"Selling an item online is easy, but making living from a business that sells online, well that’s something different entirely!"

Ultimo Magento Theme

David Presland
Member
August 1, 2014 - 1:35 pm
Member Since: July 3, 2014
Forum Posts: 102
sp_UserOfflineSmall Offline

I had the same problem Matt, only for bundled items. I re-indexed, re-cached, everything. I had my Magento tech look at it and everything was correct, stock was enabled, status was enabled, there was qtys for the bundled items, products were set to catalog search we both could see them in my Magneto catalog but they were not visible on my website. These were all items that I imported back from a CSV that I had originally exported from Magento. I ended up having to recreate them one by one in Magento for them to show up on the website.

I even compared the two side by side, and could not see any difference in the two other than one was showing on my website and the one imported back in via Magmi was not.

it was quite perplexing, I still have some of those that were imported by Magmi, that I have not re-duplicated yet. that are sitting there and just will not show up on the website.

Avatar
Matthew Ogborne

Founder
August 2, 2014 - 5:23 am
Member Since: July 18, 2013
Forum Posts: 4565
sp_UserOfflineSmall Offline

Morning,

Hmmm… I’m thinking it would be a good idea to pass this on to Sebastien Bracquemont from Magmi to see if there is an unknown bug with the plugin.

I’ve pinged him and email, however it would be an idea to add this as a bug report on source forge and see what he says.

By the way he will need access to your site/s to look at this, so include contact details as appropriate along with an example file/s too.

Matt

"Selling an item online is easy, but making living from a business that sells online, well that’s something different entirely!"

Ultimo Magento Theme

Mage Guy

New
August 18, 2014 - 8:56 am
Member Since: August 18, 2014
Forum Posts: 3
sp_UserOfflineSmall Offline

I can also confirm the same problem with bundles not showing on front end after import. Interestingly you can navigate directly to the bundle products using its URL and add the product to cart however it will not appear in its assigned category or via the search results. Everything is setup identically to manually made bundle products in the admin, all are enabled with stock. The imported bundle products show in both Manage Categories under the assigned products tab and under Manage Products but they simply refuse to show on the front end, even after reindexing etc.

David Presland
Member
August 18, 2014 - 5:38 pm
Member Since: July 3, 2014
Forum Posts: 102
sp_UserOfflineSmall Offline

Yup exactly my problem! I am back to creating them manually one by one in Magento, pain in the royal petunias

Avatar
Dave Furness

Founder
August 19, 2014 - 11:11 am
Member Since: July 19, 2013
Forum Posts: 4606
sp_UserOfflineSmall Offline

Hey Guys,

Im just going to check with Matt and see if he ever heard from Sebastien at Magmi regarding this and will hopefully get a reply over to you asap.

Dave

Every expert was once a beginner

Avatar
Matthew Ogborne

Founder
August 20, 2014 - 9:50 am
Member Since: July 18, 2013
Forum Posts: 4565
sp_UserOfflineSmall Offline

Howdy,

I didn’t hear back, however I’m tagging @Sebastien BRACQUEMONT here to let him know.

Matt

"Selling an item online is easy, but making living from a business that sells online, well that’s something different entirely!"

Ultimo Magento Theme

Avatar
Sebastien BRACQUEMONT

Excellent
August 20, 2014 - 11:23 am
Member Since: January 9, 2014
Forum Posts: 34
sp_UserOfflineSmall Offline

Hi Guys, just back from vacation.

The bundled plugin may need some investigation. could i get a sample csv to try sorting this out ?

Avatar
Dave Furness

Founder
August 21, 2014 - 9:36 am
Member Since: July 19, 2013
Forum Posts: 4606
sp_UserOfflineSmall Offline

Hey Sebastien,

Hope you had a good holiday sir!

I have just pinged @David Presland to see if he can send over a sample CSV to get this sorted

Thanks

Dave

Every expert was once a beginner

David Presland
Member
August 22, 2014 - 6:06 pm
Member Since: July 3, 2014
Forum Posts: 102
sp_UserOfflineSmall Offline

I have to find the CSV file again, but I did send it over to Matt a week or so ago

Avatar
Dave Furness

Founder
August 24, 2014 - 3:07 pm
Member Since: July 19, 2013
Forum Posts: 4606
sp_UserOfflineSmall Offline

Has anyone sent it over to Sebastien to have a look at?

Dave

Every expert was once a beginner

Avatar
Dave Furness

Founder
August 24, 2014 - 3:07 pm
Member Since: July 19, 2013
Forum Posts: 4606
sp_UserOfflineSmall Offline

Has anyone sent it over to Sebastien to have a look at?

Dave

Every expert was once a beginner

Mage Guy

New
August 29, 2014 - 8:34 am
Member Since: August 18, 2014
Forum Posts: 3
sp_UserOfflineSmall Offline

Hi guys,

Sorry for the delay, if nobody has sent a file over yet please find mine attached. It includes one bundle product line, with 4 simple products below that make up the bundle. Note when I initially imported this it was the bundle only as the simple products already existed in Magento, however I have added that data into this file. Let me know how you go or if you have any more questions. Furthermore, as a test I also tried to create a duplicate product from the bundle that was imported. The duplicated product also suffered from the same problem in that it would not show on the front-end. So whatever is missing from the imported product is also not generated by magento‘s built in product copy tool. I’m certain it is just one piece of relational data the product is expected to have that is not being added for bundles, its almost as if the product is being ignored by the template.

Thanks

Mage Guy

New
September 9, 2014 - 1:32 am
Member Since: August 18, 2014
Forum Posts: 3
sp_UserOfflineSmall Offline

Has anybody managed to take a look at the problem with bundles yet? If you add the simple products that make up the bundles to a category of their own they show up as simple products fine on the front end, so it is just the bundle product causing the problem. Looking over some of the database comparing the imported bundles to manually created ones I can see there is some additional data for the manual ones on certain tables such as product_index_price_… Its likely the import is not setting up everything it needs to for bundles.

Thanks

Avatar
tawfek daghistani

New
October 18, 2014 - 10:18 am
Member Since: October 18, 2014
Forum Posts: 1
sp_UserOfflineSmall Offline

Hello Guys ,
any body get this issue solved , I am facing the first issue only on magento 1.9 & magmi 0.7.19a
1> After importing the options don’t show up until I save the product from the admin area.

please update us

jane wong

Not so New
December 30, 2014 - 1:37 am
Member Since: September 21, 2014
Forum Posts: 4
sp_UserOfflineSmall Offline

Hi Guys,

Not sure if this is the right thread to post this in, other than I am having a similar problem with products not showing up in the frontend. The only way they will show is if I go into each product via admin and save the product. I did notice that when I go to the product via admin the url key is blank. When I imported the products, I did not fill out this field on the csv. Could that be the reason? However, I did reindex the site and the product is still not showing up on frontend. After reindexing the site, the product url key is still blank.

Thoughts?

Avatar
Matthew Ogborne

Founder
December 30, 2014 - 1:29 pm
Member Since: July 18, 2013
Forum Posts: 4565
sp_UserOfflineSmall Offline

Howdy,

Both of your questions related to the way that Magento works and what Magmi is:

Question 1

tawfek daghistani said
Hello Guys ,
any body get this issue solved , I am facing the first issue only on magento 1.9 & magmi 0.7.19a
1> After importing the options don’t show up until I save the product from the admin area.
please update us

Question 2:

jane wong said
Hi Guys,

Not sure if this is the right thread to post this in, other than I am having a similar problem with products not showing up in the frontend. The only way they will show is if I go into each product via admin and save the product. I did notice that when I go to the product via admin the url key is blank. When I imported the products, I did not fill out this field on the csv. Could that be the reason? However, I did reindex the site and the product is still not showing up on frontend. After reindexing the site, the product url key is still blank.

Thoughts?

The key point here is that you’re adding products to Magento using Magmi, then going to the website (which is called the “frontend” and not instantly seeing the products.

This is completely normal! (for Magento).

Magmi is a database extension to Magento, not a Magento extension. What this means is that when you import products in Magmi, they go straight into the Magento database and you’ll be able to see them in the admin pages (the backend).

However for them to appear on the frontend (the part that customers see), you’ll need to “re-index” the site.

Re-Indexing is covered in this video tutorial https://understandinge.com/lesson/mwf-0031/ (which is a premium one) and see here https://understandinge.com/forum/?search=1&new=1&forum=all&value=reindexing&type=3&include=1 for previous forum threads and this one https://understandinge.com/forum/getting-started/magmi-product-not-showing-on-front-end/ includes the video on how to find the paths to use to set up an automatic cron job to reindex the sites for you.

I hope that makes sense!

Matt

PS. I have assumed that you have uploaded a complete product and don’t have any missing required fields. You can confirm this by going to a product in the Magento admin that you have just imported and press save. If you get no warnings or red boxes, happy days :)

"Selling an item online is easy, but making living from a business that sells online, well that’s something different entirely!"

Ultimo Magento Theme

mike9706

New
January 7, 2015 - 4:17 pm
Member Since: January 7, 2015
Forum Posts: 3
sp_UserOfflineSmall Offline

Hi All,

I’m also struggling with the Bundle product import using Magmi. It’s the same issue described above. I can view the product on the frontend but it does not appear in the categories or on the search page, it appears fine in the backend and all required fields have been filled. When checking the imported product via admin I can see it has the appropriate products associated with it and everything is marked as in stock with a quantity. Re-indexing doesn’t seem to help, tried via admin and command line. Clearing cache doesn’t help. Statuses are set to Enabled and Visibilities are set to Catalog,Search.

Has anyone had any luck solving this problem yet? No matter how technical. I’m currently investigating the issue and will post a solution if I find one.

I’m using Magento version 1.9.0.1.

Many thanks,
Mike

mike9706

New
January 22, 2015 - 2:54 pm
Member Since: January 7, 2015
Forum Posts: 3
sp_UserOfflineSmall Offline

Hi All,

Still struggling with the Bundle product import with Magmi, has anyone managed to get it working who has experienced this issues? (Magento v1.9.0.1)

Many thanks,
Mike

 

Why Should You Join UnderstandingE?

 
  • Access to over 500 step-by-step video tutorials
  • +20 video courses available
  • Magento, M2E Pro, Magmi, eBay, Amazon & Design all covered
  • Everything is in 100% Plain English
  • Learn how to build your own multi-channel software for eBay & Amazon
  • Access to the community forums, meet fellow business owners like yourself

Join Now with 2 Clicks

 

Join now for less that £1 per day you can gain access to over 400 step-by-step video tutorials & learn how to build your very own multi-channel software.

 

Forum Timezone: Europe/London

Most Users Ever Online: 1012

Currently Online:
26 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Jim @ Moogento: 688

Steve Froggatt: 514

Badeth - UE: 513

Jimbob: 453

Paul Cartwright: 414

Forum Stats:

Groups: 6

Forums: 37

Topics: 5222

Posts: 27488

Administrators: Matthew Ogborne: 4565, Dave Furness: 4606